PAT A1058 A+B in Hogwarts
If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10的7次方 ], Sickle is an teger in [0, 17), and Knut is an integer in [0, 29)).
Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28
接下来是AC代码:
#include <iostream>
#include <cstdio>
int main(void) {
int g1,s1,k1;
int g2,s2,k2;
scanf("%d.%d.%d %d.%d.%d",&g1,&s1,&k1,&g2,&s2,&k2);
g1+=g2;
s1+=s2;
k1+=k2;
int t=k1/29;
s1+=t;
k1%=29;
t=s1/17;
g1+=t;
s1%=17;
printf("%d.%d.%d",g1,s1,k1);
return 0;
}
解题思路:
1.和算零钱一样,注意取模以及除法运算就好了
需要注意:
1.注意最高位不需要进位
2.从小钱到大钱开始计算,除法进位,取模留位
还没有评论,来说两句吧...