Silver Cow Party POJ - 3268 (Dijkstra两次最短路径)
One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.
Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.
Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?
Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
解题思路:
首先求出起点到终点的最短路径,然后在不走之前路径的前提下求出终点到起点的路径
利用两次Dijkstra即可,注意第一次Dijkstra之后要将访问的路径设置为已访问
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <vector>
#include <queue>
using namespace std;
const int MAXN = 1010;
const int INF = 0x3fffffff;
struct stEdge {
int to, stCost; //路上耗费
bool isUsed; //是否被访问
};
typedef pair<int, int> P;
int N, M, X;
vector<stEdge> Gs[MAXN];
int Ds[MAXN];
void dijkstra(int s) {
priority_queue<P, vector<P>, greater<P> > que;
fill(Ds, Ds + N + 5, INF);
Ds[s] = 0; //初始化为0
que.push(P(0,s));
while (!que.empty()) {
P p = que.top();
que.pop();
int v = p.second;
if (Ds[v] < p.first) continue;
for (int i = 0; i < Gs[v].size(); ++i) {
stEdge e = Gs[v][i];
if (!e.isUsed && Ds[e.to] > Ds[v] + e.stCost) {
e.isUsed = true;
Ds[e.to] = Ds[v] + e.stCost;
que.push(P(Ds[e.to], e.to));
}
}
}
}
int main() {
scanf("%d %d %d", &N, &M, &X);
int sx, sy, st;
for (int i = 0; i < M; ++i) {
scanf("%d %d %d", &sx, &sy, &st);
stEdge et;
et.to = sy, et.stCost = st;
Gs[sx].push_back(et);
}
int maxTres = 0;
for (int i = 1; i <= N; ++i) {
//让所有边都初始化未访问
int tempLgs = 0;
for (int j = 1; j <= N; ++j) {
for (int k = 0; k < Gs[j].size(); ++k) {
Gs[j][k].isUsed = false;
}
}
dijkstra(i);
tempLgs += Ds[X];
dijkstra(X);
tempLgs += Ds[i];
if (tempLgs > maxTres) maxTres = tempLgs;
}
printf("%d\n", maxTres);
system("PAUSE");
return 0;
}
还没有评论,来说两句吧...