(PAT) 1022 Digital Library (利用映射map存储数据,以及输入输出控制)
A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:
- Line #1: the 7-digit ID number;
- Line #2: the book title — a string of no more than 80 characters;
- Line #3: the author — a string of no more than 80 characters;
- Line #4: the key words — each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
- Line #5: the publisher — a string of no more than 80 characters;
- Line #6: the published year — a 4-digit number which is in the range [1000, 3000].
It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.
After the book information, there is a line containing a positive integer M (≤1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:
- 1: a book title
- 2: name of an author
- 3: a key word
- 4: name of a publisher
- 5: a 4-digit number representing the year
Output Specification:
For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found
instead.
Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found
解题思路:
我们使用 map
使用Map[“Mike”].insert(1001) 就可以实现加入
接下来是读入数据的问题
使用cin读取字符串的话,空格会被当成结束符,所以如果输入The Testing book的话,cin只会读入The
要读入空格的话,必须使用getline(cin,string)
同时,在用scanf()读取数据后,必须用getchar()将换行吸收掉,否则getline会把换行读入
关于这题,创建5个map存储对应的ID,然后根据用户的输入数据查询即可
#include<iostream>
#include<algorithm>
#include<map>
#include<string.h>
#include<string>
#include<set>
using namespace std;
map<string, set<int>> titleMap, authorMap, keyWordsMap, publisherMap, publisherYearMap; //存5张map
void searchInfo(map<string, set<int>>& MAP, string& content) {
if (MAP.find(content) == MAP.end()) {
cout << "Not Found" << endl;
}
else {
for (auto itr = MAP[content].begin(); itr != MAP[content].end(); ++itr) {
printf("%07d\n", *itr);
}
}
}
int main() {
int N, M;
char c; //用来吸收掉空格
scanf("%d", &N);
for (int i = 0; i < N; ++i) {
string input;
int ID;
scanf("%d", &ID);
c = getchar();
getline(cin, input);
titleMap[input].insert(ID);
getline(cin, input);
authorMap[input].insert(ID);
while (cin >> input) {
keyWordsMap[input].insert(ID);
c = getchar();
if(c == '\n') break; //如果是换行的话,退出
}
getline(cin, input);
publisherMap[input].insert(ID);
getline(cin, input);
publisherYearMap[input].insert(ID);
}
scanf("%d", &M);
for (int i = 0; i < M; ++i) {
int queryId;
string queryContent;
scanf("%d: ", &queryId);
getline(cin, queryContent);
cout << queryId << ": " << queryContent << endl;
switch (queryId)
{
case 1:
searchInfo(titleMap, queryContent);
break;
case 2:
searchInfo(authorMap, queryContent);
break;
case 3:
searchInfo(keyWordsMap, queryContent);
break;
case 4:
searchInfo(publisherMap, queryContent);
break;
case 5:
searchInfo(publisherYearMap, queryContent);
break;
default:
break;
}
}
system("PAUSE");
return 0;
}
还没有评论,来说两句吧...