1086. Tree Traversals Again (25)
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.
Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
题目大意:
代码:
#include<stdio.h>
#include<stack>
using namespace std;
struct node
{
int data;
int lchild,rchild;
}tree[50];
int pre[100],in[100],l1=0,l2=0;
int biuld(int num,int *a,int *b)
{
if(num<=0)
{
return -1;
}
tree[*a].data=*a;
int i;
for(i=0;i<num;i++)
{
if(*(b+i)==*a)
break;
}
tree[*a].lchild=biuld(i,a+1,b);
tree[*a].rchild=biuld(num-i-1,a+i+1,b+i+1);
return *a;
}
int flag=0;
void posttraverl(int root)
{
if(root!=-1)
{
posttraverl(tree[root].lchild);
posttraverl(tree[root].rchild);
if(flag==0)
{
printf("%d",root);
flag=1;
}
else
{
printf(" %d",root);
}
}
}
int main()
{
int i,j,n,m,k,t;
char operation[5];
scanf("%d",&n);
stack<int> s;
for(i=0;i<n*2;i++)
{
scanf("%s",operation);
if(operation[1]=='u')
{
scanf("%d",&m);
s.push(m);
pre[l1++]=m;
}
else
{
in[l2++]=s.top();
s.pop();
}
}
int root=biuld(n,pre,in);
posttraverl(root);
return 0;
}
还没有评论,来说两句吧...