Ubiquitous Religions【并查集】
Ubiquitous Religions
There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.
You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input
The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output
For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample Output
Case 1: 1
Case 2: 7
Hint
Huge input, scanf is recommended.
题意概括:
有n个人,给出m对人,每对人有相同的宗教信仰,求有多少个不同的宗教信仰。
解题分析:
其实就是找每个人的祖先,拥有相同祖先的人表示拥有相同的宗教信仰,最后统计有多少个祖先就行了。
错题分析:
注意数据量,m的值较大,先存到数组里再用,空间是不够的,会造成RE。
AC代码:
#include<stdio.h>
#include<string.h>
#define N 60000
int f[N];
int Find(int v)
{
if(f[v] == v) return v;
f[v] = Find(f[v]);
return f[v];
}
void Union(int u, int v)
{
int t1 = Find(u), t2 = Find(v);
if(t1 != t2) f[t2] = t1;
return ;
}
int main()
{
int i, n, m, t = 1, ans, a, b;
while(scanf("%d%d", &n, &m), n || m){
for(i = 1; i <= n; i++) f[i] = i;
for(i = ans = 0; i < m; i++){
scanf("%d%d", &a, &b);
Union(a, b);
}
for(i = 1; i <= n; i++) if(f[i] == i) ans++;
printf("Case %d: %d\n", t++, ans);
}
return 0;
}
还没有评论,来说两句吧...