HDU 5533 Dancing Stars on Me (暴力模拟+思维)
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.
Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
Input
The first line contains a integer T T indicating the total number of test cases. Each test case begins with an integer n n, denoting the number of stars in the sky. Following n n lines, each contains 2 2 integers xi,yi xi,yi, describe the coordinates of n nstars.
1≤T≤300 1≤T≤300
3≤n≤100 3≤n≤100
−10000≤xi,yi≤10000 −10000≤xi,yi≤10000
All coordinates are distinct.
Output
For each test case, please output “`YES`“ if the stars can form a regular polygon. Otherwise, output “`NO`“ (both without quotes).
Sample Input
3
3
0 0
1 1
1 0
4
0 0
0 1
1 0
1 1
5
0 0
0 1
0 2
2 2
2 0
Sample Output
NO
YES
NO
题解:
题意:
给你n个点,问你是否可以组成一个正n变形。。。
思路:
本来是个挺好的题,懒得看英文搜题意的时候不小心瞄了一眼题解。。然后这题就被无情得ac了(捂脸),暴力遍历所有边,因为多边形的边是最短的,所以只要找到最短的边,看所有边里面长度与最短边相同的边是否有n个就好了
代码:
#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<deque>
#include<algorithm>
#define ll long long
#define INF 100861111
#define M (t[k].l+t[k].r)/2
#define lson k*2
#define rson k*2+1
using namespace std;
struct node
{
ll x,y;
}a[105];
ll b[5005];
int main()
{
int test,i,j,n,ans;
scanf("%d",&test);
while(test--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%lld%lld",&a[i].x,&a[i].y);
}
ans=0;
for(i=0;i<n;i++)
{
for(j=i+1;j<n;j++)
{
b[ans]=(a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y);
ans++;
}
}
sort(b,b+ans);
int num=1;
for(i=1;b[i]==b[0]&&num!=n;i++)
num++;
if(num==n)
printf("YES\n");
else
printf("NO\n");
}
}
还没有评论,来说两句吧...