To The Max
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range −127,127 −127,127.
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
Sample Output
15
题意:找最大的矩阵和
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n;
int maxsum(int f[])
{
int dp[101],sum=f[1];
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
{
dp[i]=max(dp[i],dp[i-1]+f[i]);
sum=max(sum,dp[i]);
}
return sum;
}
int main()
{
int a[101][101];
while(~scanf("%d",&n))
{
memset(a,0,sizeof(a));
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
scanf("%d",&a[i][j]);
a[i][j]=a[i-1][j]+a[i][j];//将前面的每一行累加的下一行
}
}
int s[101],maxx=a[1][1];
for(int i=1;i<=n;i++)//遍历每一个区域
{
memset(s,0,sizeof(s));
for(int j=i;j<=n;j++)
{
for(int l=1;l<n;l++)
s[l]=a[j][l]-a[i-1][l];
maxx=max(maxx,maxsum(s));
}
}
printf("%d\n",maxx);
}
return 0;
}
还没有评论,来说两句吧...