Fence Repair (哈弗曼树+快排) poj 3253 c++
Fence Repair
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 26361 | Accepted: 8550 |
Description
Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.
FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.
Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.
Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.
Input
Line 1: One integer N, the number of planks
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank
Output
Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts
Sample Input
3
8
5
8
Sample Output
34
Hint
He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
题意:有一块长木板,要经过n-1次切割将其切成n块农夫FJ想要的木板,对于每块木板,每切割一次,将会消耗和这条木板长度值相等的金钱,问最少需要多少钱,可将木板切成自己想要的n块,求最少花费。
思路:直接利用哈弗曼树做会超时,这里用一个sort排序,把最小的两个数相加前面两个舍弃,和加入数组,与后面的一次对比交换,就可以了。
注意:用__int64.
参考代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
long long sum,a[200020];
int main()
{
int i,j,n,b;
while(scanf("%d",&n)!=EOF)
{
sum=0;
b=0;
for(i=0;i<n;i++)
scanf("%I64d",&a[i]);
sort(a,a+n);
for(i=0;i<n-1;i++)
{
b=a[i+1]+a[i];
sum+=b;
for(j=i+2;j<n;j++)
{
if(b>=a[j])
a[j-1]=a[j];
else
{
a[j-1]=b;
break;
}
}
if(j==n)
a[j-1]=b;
}
printf("%I64d\n",sum);
}
return 0;
}
还没有评论,来说两句吧...