A Simple Task
A Simple Task
#
Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.
Example
For n = 24, o = 3 and p = 3.
Task
Write a program which for each data set:
reads a positive integer n,
computes the odd integer o and the nonnegative integer p such that n = o2^p,
writes the result.
输入
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.
Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
输出
The output should consists of exactly d lines, one line for each data set.
Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.
示例输入
1
24
示例输出
3 3
提示
zoj1382有链接提示的题目请先去链接处提交程序,AC后提交到SDUTOJ中,以便查询存档。
来源
面向对数据结构和算法不太懂的同学
#include<stdio.h>
#include<math.h>
int main()
{
int i,j,n,m,k,t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=1;i<=n;i+=2)
for(j=0;i*(pow(2,j))<=n;j++)
if(i*(pow(2,j))==n)
printf("%d %d\n",i,j);
}
}
还没有评论,来说两句吧...