NYOJ 436 sum of all integer numbers
sum of all integer numbers
时间限制: 1000 ms | 内存限制: 65535 KB
难度: 0
描述
Your task is to find the sum of all integer numbers lying between 1 and N inclusive.
输入
There are multiple test cases.
The input consists of a single integer N that is not greater than 10000 by it’s absolute value.
输出
Write a single integer number that is the sum of all integer numbers lying between 1 and N inclusive.
样例输入
3
样例输出
6
思路:坑爹的题目。
#include<stdio.h>
int main()
{
int n;
while(scanf("%d",&n) != EOF)
{
if (n>0)
{
printf("%d\n",(n*(n+1)) >> 1);
}
else if (n == 0)
{
printf("1\n");
}
else
{
printf("%d\n",1-((n*(n-1)) >> 1));
}
}
}
还没有评论,来说两句吧...