【杭电oj1096】A+B for Input-Output Practice (VIII)
A+B for Input-Output Practice (VIII)
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 138701 Accepted Submission(s): 42471
Problem Description
Your task is to calculate the sum of some integers.
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3
Sample Output
10
15
6
Author
lcy
Recommend
JGShining | We have carefully selected several similar problems for you: 1001 1000 1040 1108 1008
Statistic | Submit | Discuss | Note
#include<stdio.h>
int main() {
int i,j,k,n;
scanf("%d",&n);
while(n--) {
int sum=0;
scanf("%d",&k);
for(int l=0; l<k; l++) {
scanf("%d",&i);
sum+=i;
}
if(n!=0)
printf("%d\n\n",sum);
else
printf("%d\n",sum);
}
return 0;
}
还没有评论,来说两句吧...