L - The Dole Queue
In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counterclockwise up to N (who will be standing on 1’s left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise,counting m applicants. The two who are chosen are then sent off for retraining; if both officials pickthe same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.
Input
Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0,0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).
Output
For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counterclockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma). Note: The symbol ⊔ in the Sample Output below represents a space.
Sample Input
10 4 3
0 0 0
Sample Output
␣␣4␣␣8,␣␣9␣␣5,␣␣3␣␣1,␣␣2␣␣6,␣10,␣␣7
#include<stdio.h>
#include<string.h>
int main()
{
int a[22], i, j, n, t, k, m, left, right;
while(scanf("%d %d %d", &n, &k ,&m) == 3 && n && m && k)
{
memset(a, 0, sizeof(a));
for(i=1; i<=n; ++i)
a[i] = i;
t = 0;
left = 0, right = n;
while(t < n)
{
if( t )
printf(",");
i = j = 0;
while(!a[left])
{
left++;
left = left%n ? left%n : n;
}
while(!a[right])
{
right--;
right = right <= 0 ? n : right;
}
while(i<k)
{
if(a[(left = left%n? left%n: n)])
i++;
if(i >= k)
continue;
left = left%n + 1;
}
while(j<m)
{
if(a[(right = right%n ? right%n : n)])
j++;
if(j >= m)
continue;
right = right - 1 ? right - 1 : n;
}
printf("%3d", a[left]);
a[left] = 0;
t++;
if(left != right)
{
printf("%3d", a[right]);
a[right] = 0;
t++;
}
}
printf("\n");
}
return 0;
}
还没有评论,来说两句吧...