1089 A+B for Input-Output Practice (I)
1089 A+B for Input-Output Practice (I)
目录
Problem Description
Your task is to Calculate a + b.
Too easy?! Of course! I specially designed the problem for acm beginners.
You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim.
Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.
Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
Sample Input
1 5
10 20
Sample Output
6
30
Author
lcy
Recommend
JGShining
Code
Problem1089.java
import java.util.*;
public class Problem1089 {
public static void main(String[] args) {
int a,b,sum,i;
List<Integer> list = new ArrayList<>();
Scanner reader=new Scanner(System.in);
while(reader.hasNextInt()) {
a=reader.nextInt();
b=reader.nextInt();
sum =a+b;
list.add(sum);
}
Integer[] intArray = list.toArray(new Integer[list.size()]);
for(i = 0;i<intArray.length;i++){
System.out.println(intArray[i]);
}
}
}
能力不足,实在无法写成题目所说的那样,只能由写入一个非int类型的值进行循环中断,望大神指教。
还没有评论,来说两句吧...