2019 PAT甲级秋季考试7-2 Merging Linked Lists (25 分)
算法笔记总目录
Given two singly linked lists L1=a1→a2→⋯→an−1→an and L2=b1→b2→⋯→bm−1→bm. If n≥2m, you are supposed to reverse and merge the shorter one into the longer one to obtain a list like a1→a2→bm→a3→a4→bm−1⋯. For example, given one list being 6→7 and the other one 1→2→3→4→5, you must output 1→2→7→3→4→6→5.
Input Specification:
Each input file contains one test case. For each case, the first line contains the two addresses of the first nodes of L1 and L2, plus a positive N (≤105) which is the total number of nodes given. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is a positive integer no more than 105, and Next is the position of the next node. It is guaranteed that no list is empty, and the longer list is at least twice as long as the shorter one.
Output Specification:
For each case, output in order the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 01000 7
02233 2 34891
00100 6 00001
34891 3 10086
01000 1 02233
00033 5 -1
10086 4 00033
00001 7 -1
Sample Output:
01000 1 02233
02233 2 00001
00001 7 34891
34891 3 10086
10086 4 00100
00100 6 00033
00033 5 -1
题目未开放,代码只对样例进行了测试
#include <bits/stdc++.h>
using namespace std;
const int maxn = 100005;
struct Node{
int address,data,nexto,nextt;
}node[maxn];
int main(){
int s1,s2,n,k=0;
cin>>s1>>s2>>n;
for(int i=0;i<n;i++){
int ad,data,next;
cin>>ad>>data>>next;
node[ad].data=data;
node[ad].nexto=next;
node[ad].address=ad;
}
while(node[s1].nexto != -1){ //反向链表建立
int s=node[s1].nexto; //当前节点
node[s].nextt=node[s1].address;
s1=node[s1].nexto;
}
for(int i=1;i<n;i++){
if(i%3==1){
printf("%05d %d %05d\n",node[s2].address,node[s2].data,node[s2].nexto);
s2=node[s2].nexto;
}else if(i%3==2){
printf("%05d %d %05d\n",node[s2].address,node[s2].data,node[s1].address);
s2=node[s2].nexto;
}else if(i%3==0){
printf("%05d %d %05d\n",node[s1].address,node[s1].data,node[s2].address);
s1=node[s1].nextt;
}
}
if(n%3==0)printf("%05d %d -1\n",node[s1].address,node[s1].data);
else printf("%05d %d -1\n",node[s2].address,node[s2].data);
return 0;
}
还没有评论,来说两句吧...