PAT 甲级 1077 Kuchiguse (20 分)
1077 Kuchiguse (20 分)
The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:
- Itai nyan~ (It hurts, nyan~)
- Ninjin wa iyada nyan~ (I hate carrots, nyan~)
Now given a few lines spoken by the same character, can you find her Kuchiguse?
Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.
Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai
.
Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
Sample Output 1:
nyan~
Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T
Sample Output 2:
nai
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
string com="",temp;
int i,j,n,c,t;
cin>>n;
getchar();
getline(cin,com);
for(i=1;i<n;i++)
{
getline(cin,temp);
c=com.length()-1;
t=temp.length()-1;
while(com[c]==temp[t])
{
c--;
t--;
if(c<0||t<0) // 这点我错过
break;
}
if(c==com.length()-1)
{
com="nai";
}
else
{
com=com.substr(c+1);
}
}
cout<<com<<endl;
return 0;
}
还没有评论,来说两句吧...