TOJ 1538 A Walk Through the Forest Spfa+DFS
1538: A Walk Through the Forest
描述
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
输入
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.
输出
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
样例输入
5 6
1 3 2
1 4 2
3 4 3
1 5 12
4 2 34
5 2 24
7 8
1 3 1
1 4 1
3 7 1
7 4 1
7 5 1
6 7 1
5 2 1
6 2 1
0
样例输出
2
4
题目很神奇,如果A走到家比B走到家更近的话,就可以B-A-家,所以要先算出所有点到家的距离,然后DFS路径总条数。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<string>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<vector>
using namespace std;
#define inf 0x3f3f3f3f
#define LL long long
int n,ma[1005][1005],dt[1005];
struct node
{
int d,f;
}N[1005];
void spfa()
{
queue<int> Q;
int now,i;
N[2].d=0;
N[2].f=1;
Q.push(2);
while(!Q.empty())
{
now=Q.front();
Q.pop();
N[now].f=0;
for(i=1;i<=n;i++)
if(ma[now][i]!=-1)
{
if(N[i].d>N[now].d+ma[now][i])
{
N[i].d=N[now].d+ma[now][i];
if(N[i].f==0)
{
N[i].f=1;
Q.push(i);
}
}
}
}
}
int dfs(int now)
{
int i;
if(dt[now]>0)
return dt[now];
if(now==2)
return 1;
for(i=1;i<=n;i++)
if(ma[now][i]!=inf&&N[now].d>N[i].d)
dt[now]+=dfs(i);
return dt[now];
}
int main()
{
int m,i,j,n1,n2,d;
while(scanf("%d",&n))
{
if(n==0)break;
scanf("%d",&m);
memset(ma,inf,sizeof ma);
memset(dt,0,sizeof dt);
for(i=1;i<=n;i++)
{
N[i].d=inf;
N[i].f=0;
}
while(m--)
{
scanf("%d%d%d",&n1,&n2,&d);
if(ma[n1][n2]>d)
ma[n1][n2]=ma[n2][n1]=d;
}
spfa();
printf("%d\n",dfs(1));
}
}
还没有评论,来说两句吧...