java多项式求和

偏执的太偏执、 2022-06-16 20:46 360阅读 0赞



Problem Description

多项式描述如下:

1 - 1/2 + 1/3 - 1/4 + 1/5 - 1/6 ……

先请你求出多项式前n项的和。

Input

第一行输入一个数T代表测试数据个数(T<=1000)。接下来T行每行1个数代表n(0<=n< 2^31)。

Output

对于每个输入样例,输出多项式和的结果(结果精确到小数点后两位)。每行输出一个结果。

Example Input

  1. 2
  2. 1
  3. 2

Example Output

  1. 1.00
  2. 0.50

import java.util.Scanner;
public class Main
{
public static void main(String[] args)
{
Scanner reader=new Scanner(System.in);
int t;
t=reader.nextInt();
while(t—>0)
{
int n;
n=reader.nextInt();
n=Math.min(n,1000);
double flag=1;
double sum=0.0;
for(int i=1;i<=n;i++)
{
sum=sum+flag/i;
flag=-flag;
}
System.out.printf(“%.2f”,sum);
System.out.println();
}

}
}

发表评论

表情:
评论列表 (有 0 条评论,360人围观)

还没有评论,来说两句吧...

相关阅读