【lightoj1043】几何数学
D - D 使用long long
Time Limit:500MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Submit Status Practice LightOJ 1043 uDebug
Description
See the picture below.
You are given AB, AC and BC. DE is parallel to BC. You are also given the area ratio between ADE and BDEC. You have to find the value ofAD.
Input
Input starts with an integer T (≤ 25), denoting the number of test cases.
Each case begins with four real numbers denoting AB, AC, BC and the ratio of ADE and BDEC (ADE / BDEC). You can safely assume that the given triangle is a valid triangle with positive area.
Output
For each case of input you have to print the case number and AD. Errors less than 10-6 will be ignored.
Sample Input
4
100 100 100 2
10 12 14 1
7 8 9 10
8.134 9.098 7.123 5.10
Sample Output
Case 1: 81.6496580
Case 2: 7.07106781
Case 3: 6.6742381247
Case 4: 7.437454786
简单几何题,相似三角形,几个输入数据都用不到。
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
int main() {
int T,p=0;
scanf("%d",&T);
while(T--) {
double a,b,c,d;
scanf("%lf%lf%lf%lf",&a,&b,&c,&d);
double cnt=sqrt(d/(d+1));
printf("Case %d: %.6lf\n",++p,cnt*a);
}
return 0;
}
还没有评论,来说两句吧...