【lightoj1294】数学
H - H 使用long long
Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Submit Status Practice LightOJ 1294 uDebug
Description
Given two integers: n and m and n is divisible by 2m, you have to write down the first n natural numbers in the following form. At first take first mintegers and make their sign negative, then take next m integers and make their sign positive, the next m integers should have negative signs and continue this procedure until all the n integers have been assigned a sign. For example, let n be 12 and m be 3. Then we have
-1 -2 -3 +4 +5 +6 -7 -8 -9 +10 +11 +12
If n = 4 and m = 1, then we have
-1 +2 -3 +4
Now your task is to find the summation of the numbers considering their signs.
Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.
Each case starts with a line containing two integers: n and m (2 ≤ n ≤ 109, 1 ≤ m). And you can assume that n is divisible by 2*m.
Output
For each case, print the case number and the summation.
Sample Input
2
12 3
4 1
Sample Output
Case 1: 18
Case 2: 2
规律题,我开始还想着打表,后来发现规律了轻松ac
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define LL long long
using namespace std;
//void init() {
// for(int i=1; i<n; i++) {
// a[i]=a[i-1]+i;
// }
//}
int main() {
int T,p=0;
scanf("%d",&T);
while(T--) {
LL n,m;
scanf("%lld%lld",&n,&m);
LL cnt=0;
cnt=n/(2*m)*m;
printf("Case %d: %lld\n",++p,cnt*m);
}
return 0;
}
还没有评论,来说两句吧...