DNA Sorting--hdu1379

野性酷女 2022-08-04 08:53 201阅读 0赞

DNA Sorting

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2203 Accepted Submission(s): 1075

Problem Description

One measure of ``unsortedness’’ in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC’’, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG’’ has only one inversion (E and D)—it is nearly sorted—while the sequence ``ZWQM’’ has 6 inversions (it is as unsorted as can be—exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness’’, from ``most sorted’’ to ``least sorted’’. All the strings are of the same length.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted’’ to ``least sorted’’. If two or more strings are equally sorted, list them in the same order they are in the input file.

Sample Input

1 10 6

AACATGAAGG

TTTTGGCCAA

TTTGGCCAAA

GATCAGATTT

CCCGGGGGGA

ATCGATGCAT

Sample Output

CCCGGGGGGA

AACATGAAGG

GATCAGATTT

ATCGATGCAT

TTTTGGCCAA

TTTGGCCAAA

这个题开始就没读懂,所以也不会做,后来学长讲完后才明白啥意思;

就是比如第一行数据AACATGAAGG 首先定义sum=0, A大于它后面字符的个数为0,sum+=0,第二个同样,第三个C大于它后面字符的个数为3,sum+=3。。。以此类推!

然后按每行数字从小到大输出字符串!!!

  1. 1 #include<stdio.h>
  2. 2 #include<string.h>
  3. 3 #include<algorithm>
  4. 4 using namespace std;
  5. 5 struct as
  6. 6 {
  7. 7 char s[101];
  8. 8 int m;
  9. 9 }aa[200];
  10. 10 bool cmp(as s,as t)
  11. 11 {
  12. 12 return s.m < t.m;
  13. 13 }
  14. 14 int main()
  15. 15 {
  16. 16 int n,i,j,k,t,a,b,q;
  17. 17 scanf("%d",&n);
  18. 18 while(n--)
  19. 19 {
  20. 20 scanf("%d%d",&a,&b);
  21. 21 getchar();
  22. 22 for(k=0;k<b;k++)
  23. 23 {
  24. 24
  25. 25 scanf("%s",aa[k].s);
  26. 26 {
  27. 27 for(t=0;t<a;t++)
  28. 28 {
  29. 29 int sum=0;
  30. 30 for(i=0;i<a-1;i++)
  31. 31 {
  32. 32 for(j=i+1;j<a;j++)
  33. 33 if(aa[t].s[i]>aa[t].s[j])
  34. 34 sum++;
  35. 35 }
  36. 36 aa[t].m=sum;//将各组总数放在结构体中
  37. 37 }
  38. 38
  39. 39 }
  40. 40 }
  41. 41 sort(aa, aa+b, cmp);//排序结构体
  42. 42 for(i=0;i<b;i++)
  43. 43 printf("%s\n",aa[i].s);
  44. 44 }
  45. 45 return 0;
  46. 46 }

发表评论

表情:
评论列表 (有 0 条评论,201人围观)

还没有评论,来说两句吧...

相关阅读

    相关 DNA序列

    > 一个DNA序列由A/C/G/T四个字母的排列组合组成。G和C的比例(定义为GC-Ratio)是序列中G和C两个字母的总的出现次数除以总的字母数目(也就是序列长度)。在基因工

    相关 变色DNA

    有一只特别的狼,它在每个夜晚会进行变色,研究发现它可以变成N种颜色之一,将这些颜色标号为0,1,2...N-1。研究发现这只狼的基因中存在一个变色矩阵,记为colormap,如