求二叉树的先序遍历
求二叉树的先序遍历
#
Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历
输入
输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的中序遍历序列,第二个字符串表示二叉树的后序遍历序列。
输出
输出二叉树的先序遍历序列
示例输入
2
dbgeafc
dgebfca
lnixu
linux
示例输出
abdegcf
xnliu
提示
来源
GYX
示例程序
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
int data;
struct node *lchild,*rchild;
};
struct node *creat(int n,char *a,char *b)
{
struct node *root;
char *p;
if(n==0)
return NULL;
root=(struct node *)malloc(sizeof(struct node));
root->data=a[n-1];
for(p=b;p!='\0';p++)
if(*p==a[n-1])
break;
int t;
t=p-b;
root->lchild=creat(t,a,b);
root->rchild=creat(n-t-1,a+t,p+1);
return root;
}
void qianxu(struct node *root)
{
if(root)
{
printf("%c",root->data);
qianxu(root->lchild);
qianxu(root->rchild);
}
}
int main()
{
int i,j,n,m,k,t;
struct node *root;
root=(struct node *)malloc(sizeof(struct node));
char a[100],b[100];
while(scanf("%d",&n)!=EOF)
{
while(n--)
{
scanf("%s %s",b,a);
m=strlen(a);
root=creat(m,a,b);
qianxu(root);
printf("\n");
}
}
}
还没有评论,来说两句吧...