(PAT 1108) Finding Average (字符串处理)
The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.
Output Specification:
For each illegal input number, print in a line ERROR: X is not a legal number
where X
is the input. Then finally print in a line the result: The average of K numbers is Y
where K
is the number of legal inputs and Y
is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined
instead of Y
. In case K
is only 1, output The average of 1 number is Y
instead.
Sample Input 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
Sample Output 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
Sample Input 2:
2
aaa -9999
Sample Output 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
解题思路:
直接无脑if else就行了,这里的坑点是要仔细读题,注意最后的number和numbers!
关于string转float 用stof就可以了
#include <iostream>
#include <algorithm>
#include <string>
using namespace std;
int N;
int main() {
cin >> N;
string tnum;
float sum = 0.0;
int nn = 0;
for (int i = 0; i < N; ++i) {
int countpoint = 0;
bool countpointDug = true;
bool islegal = true;
int numbernum = 0;
int countnumber = 0;
bool zeroflag = true;
cin >> tnum;
for (int j = 0; j < tnum.length(); ++j) {
//判断负号
if (tnum[j] == '-') {
if (j == 0) {
continue;
}
else {
islegal = false;
break;
}
}
//判断小数点
if (tnum[j] == '.') {
countpoint++;
if (countpoint > 1) {
islegal = false;
break;
}
continue;
}
//判断是否是字符
if (tnum[j] >= 0 + '0' && tnum[j] <= 9 + '0') {
numbernum++;
if (countpoint == 1) countnumber++;
if (countpoint == 0 && numbernum > 4) {
islegal = false;
break;
}
if (countpoint == 1 && countnumber > 2) {
islegal = false;
break;
}
}
else {
islegal = false;
break;
}
}
if (!islegal) {
cout << "ERROR: "<<tnum<<" is not a legal number" << endl;
}
else {
float dres = stof(tnum);
if(dres<-1000 || dres > 1000) cout << "ERROR: " << tnum << " is not a legal number" << endl;
else {
sum += dres;
nn++;
}
}
}
if (nn == 0) {
printf("The average of 0 numbers is Undefined\n");
}
else if (nn == 1) {
printf("The average of 1 number is %.2f\n",sum); //坑点在这里!!请仔细读题
}
else{
printf("The average of %d numbers is %.2f", nn, sum / nn);
}
return 0;
}
还没有评论,来说两句吧...