1108 Finding Average (20 分) 字符串处理 sscanf和sprintf 格式化
The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.
Output Specification:
For each illegal input number, print in a line ERROR: X is not a legal number
where X
is the input. Then finally print in a line the result: The average of K numbers is Y
where K
is the number of legal inputs and Y
is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined
instead of Y
. In case K
is only 1, output The average of 1 number is Y
instead.
Sample Input 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
Sample Output 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
Sample Input 2:
2
aaa -9999
Sample Output 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
题意:把合法的数字加起来算平均值,合法:[-1000,1000]的最多两位小数的数。
发现了一个神奇的东西!sscanf和sprintf 格式化!省去了很多判断!
sscanf与scanf等价,所不同的是,前者的输入字符来源于字符串s,而scanf以stdin作为输入源。
sscanf(“123456 “, “%4s”, buf); 取指定长度的字符串
取到指定字符为止的字符串。如在下例中,取遇到空格为止字符串。
sscanf(“123456 abcdedf”, “%[^ ]“, buf);
printf(“%s\n”, buf);
结果为:123456
sprintf(s, “%d”, 123); //产生”123”
更多用法:https://www.cnblogs.com/wangtianxj/archive/2009/07/04/1516646.html
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
using namespace std;
int main()
{
int n,i,j,l,sum=0;//sum 合法数
double s=0,temp;
char a[105],b[105];
scanf("%d",&n);
for(i=0;i<n;i++)
{
int f=0;
scanf("%s",a);
sscanf(a,"%lf",&temp);
sprintf(b,"%.2f",temp);
//cout<<a<<" "<<b<<" "<<temp<<endl;
for(int j=0;j<strlen(a);j++)
{
if(a[j]!=b[j]) f=1;
}
if(f||temp<-1000|| temp>1000)
{
printf("ERROR: %s is not a legal number\n",a);
continue;
}
else
{
s+=temp;
sum++;
}
}
if(sum==0)
printf("The average of 0 numbers is Undefined\n");
else if(sum==1)
printf("The average of 1 number is %.2lf\n",s/sum);
else
printf("The average of %d numbers is %.2lf\n",sum,s/sum);
}
还没有评论,来说两句吧...